"Dropdown menu" i3 help needed
#1
Hi Luke.
I tried to copy some of your i3 config in order to imitate your "dropdown menu".

``
set $term --no-startup-id termite 



# Move git term to scratchpad, open it with mod+g
for_window [instance="git"] floating enable
for_window [instance="git"] resize set 800 300
for_window [instance="git"] move scratchpad
for_window [instance="git"] border pixel 5
exec_always --no-startup-id $term -t git 

bindsym $mod+g [instance="git"] scratchpad show; [instance="git"] move position center

```

But all it does is to open a terminal on startup with the name "git" and I can't hide it an call it with `mod+g
, any clever thoughts on this?
Reply
#2
Double check termite's man---I think you want to use --name=git rather than the -t option. These are different properties.
Reply
#3
(06-11-2018, 06:54 PM)Luke Wrote: Double check termite's man---I think you want to use --name=git rather than the -t option. These are different properties.

Thanks! that did it.
and btw thanks for the pandoc videos on your YT! I've been using LaTeX for 8 years without knowing Pandoc existed, which is way more convenient for taking notes in class.
Reply
#4
(06-11-2018, 05:29 PM)notaduck Wrote: exec_always --no-startup-id $term -t git

exec_always will execute that on every i3 restart. You might wantto launch it once, in which what exec do.
Reply
#5
(06-12-2018, 02:42 AM)Daenarii Wrote:
(06-11-2018, 05:29 PM)notaduck Wrote: exec_always --no-startup-id $term -t git

exec_always will execute that on every i3 restart. You might wantto launch it once, in which what exec do.

It is already removed ;) It was only for a quick test.
Reply
#6
(06-12-2018, 01:38 AM)notaduck Wrote:
(06-11-2018, 06:54 PM)Luke Wrote: Double check termite's man---I think you want to use --name=git rather than the -t option. These are different properties.

Thanks! that did it.
and btw thanks for the pandoc videos on your YT! I've been using LaTeX for 8 years without knowing Pandoc existed, which is way more convenient for taking notes in class.

Thanks a lot! Glad it works. Wink
Reply
#7
(06-12-2018, 07:03 PM)Luke Wrote:
(06-12-2018, 01:38 AM)notaduck Wrote:
(06-11-2018, 06:54 PM)Luke Wrote: Double check termite's man---I think you want to use --name=git rather than the -t option. These are different properties.

Thanks! that did it.
and btw thanks for the pandoc videos on your YT! I've been using LaTeX for 8 years without knowing Pandoc existed, which is way more convenient for taking notes in class.

Thanks a lot! Glad it works. Wink

Yup me to ;)
Reply


[-]
Quick Reply
Message
Type your reply to this message here.


Forum Jump:


Users browsing this thread: 1 Guest(s)